Return to Level1Techs.com

2013 iMac high fan speed, internal display not working - now with error codes

First off, bit of a background. We do development at work using Visual Studio for Mac, which is the worst IDE ever but I digress, and I used to use my Hackintosh partition on my old T430 if I needed to work from home.

Recently I switched to a T440p and not had time to piss about installing MacOS yet (be it in a VM or on bare metal), and was given this iMac on the basis that it didn’t work, and the Apple store quoted £900 to replace the ‘faulty’ motherboard. I’d like to fix it so I can keep my Thinkpad free of MacOS and Windows.

The iMac suffers from being extremely slow in any Apple utility (like the recovery) and the internal display does not work.

I cannot remember the model number, but it has an i5 4570R, 8GB RAM, 1TB 5400RPM (!) HDD, and Iris Pro graphics.

Thing is, it does actually work. I can successfully boot into Linux and use it as normal, and it also boots into Windows. Linux Mint does not recognise the internal screen at all. MacOS is currently not installed on the machine as it was used for gaming believe it or not. I’ve taken the whole thing apart, which wasn’t fun with all the bloody glue, cleaned the dust, repasted CPU, and resat everything. Though it doesn’t seem to have done much in the way of fixing it. Also tried different RAM.

From watching Louis Rossman videos it appears to have the symptoms of sensor failure, but with my untrained eye I cannot see any damage to the board.

Does anyone have the slightest idea where I can start looking for fixes? I don’t care much for the internal display as I can always use an external one, but I need to get MacOS on it and running at normal speed, and seeing as the recovery stuff takes 5 mins to load with a spinning wheel in the corner I don’t think that will happen.

That machine is slow because of the hard drive. That drive should at best be storage only. Find another drive first and clone over the recovery partition using dd or something.

Next, if its still slow try ram and look behind the cpu. Theres usually a temp sensor there. If that temp sensor is busted or gone it’ll throttle.

Good luck!

Yeah I gathered the HDD is useless, have a few 7200 rpm drives which I will try again with.

I don’t recall seeing anything on the back side of the motherboard which resembled a chip of any kind though.

Could you provide the five character model number?

Like A1174 or something like that.

It could be a faulty cable that connects the sensor. As for the display working on one Linux distro vs another is a bit curious. Maybe another faulty cable or loose connection?

I think it’s an A1418, will double check when home.

To clarify, the internal display does not work at all and it’s happy to display the Mac recovery stuff as well as the OS to the external display, but does not want to show the boot selection on the external display.

Often these sensors are the size of a capacitor, just with 4 pins rather than 2.

Everyone likes pictures, right? Here is the heap in question.

Pictures looked much better on my phone…

I tried installing Mojave last night on a different HDD from a Kingston USB 3 drive which I’ve used hundreds of times to install all sorts. Took a while to load the utilities screen, I clicked ‘Continue’ on the installer, and stood there for 5 minutes. It did nothing, so I went to bed. Checked this morning and it is still stuck on the same screen, though it does look like the computer went to sleep.

And here is the motherboard.

I have managed to get an OS on this thing, here are the sensor readings. Also, it always idles at 60-70% CPU.

Looks like you’ve got a sensor problem. 250C, LOL, sounds like you’ve got an oven there. That may be the whole problem right there. Your CPU/GPU might be throttling hard because of the bad readings. This would seem to be the case since the CPU is only drawing 3 watts.

You could try running Intel Power Gadget to see the actual clock speed the Mac’s CPU is running at. Theory: Linux and Windows are OK because they just ignore the ambient sensors…maybe?

Have you tried running the onboard diagnostics? Hold down D while booting…

1 Like

CPU is throttling at 800 Mhz and GPU is at 200 Mhz, that explains why it’s so slow. I will run Apple diagnostics now but it’s likely to just return with no display detected.

Came back with an SMC issue (PFM006) and display (VFD001).

Surfing through Rossman’s forums, one possibility is that the whole SMC is kaput. The other possibilities are a bad sensor or cable. Those with Macbooks frequently mention the trackpad sensor, but I’m not what would be an analgous sensor in an iMac. Assuming you can locate it, have you inspected the SMC for damage? Some have tried soldering a new SMC on the logic board.

There is no obvious damage to the board. Frustrating thing is a post on Stack Exchange about exactly the same symptoms I have with this one but it has no resolution. :frowning:

Other thing is I cannot find a copy of ASD 3s157 anywhere, which would be incredibly useful.

Don’t exactly want to throw money at this thing as I’d rather throw a quad core, 16GB RAM, and a 1TB SSD in my T440p and get a Mac OS VM running instead.

For me, anyway, trying to get that thing to load MacOS seems like more trouble than its worth. Since it is official Mac hardware, I wonder if you could run MacOS in a VM…

EDIT: To clarify, I meant run a MacOS VM … on the iMac. But if it’s easier to do on your other hardware…

@lte Did you ever find a resolution on this? I have the exact same issues and have scoured the web to no avail on a solution. Thanks!