2 different ram kits unstable at 2133mhz with ryzen

I have two kits, f43200c16d32gvk and f43200c14d32gvk. Neither work at 2133mhz no matter what I do. At this point it’s beyond me and what I can find on google. I’ve tried timing it in myself but haven’t got anywhere. I get bsod kmode, and page fault mostly. I also get black screens. Cpu is 1800x at stock speeds and overvolted to 1.3v no llc. Soc is at 1.118 no llc under load it goes to 1.1v at the svi2 sensor. Motherboard is crosshair vi hero. I’ve tried a ton of things at this point so forgive me if I forget to mention something.
Vddp from 870mv-1v
cldo_vddp 870mv-970mv
soc auto-1.2v
cpu vcore auto-1.343 level 3 llc
vttddr auto @1.2v vdimm -auto @ 1.4vdimm also the settings around 1.35vdimm was like .6739 and .679 tried both
global c states off and on
gdm off and on 2t off 1t on
vdimm power down off and on
I’ve done these timings and the , indicates where I increased them
tcl 16
trcdwr 16
trcdrd 16
trp 16
tcl+trc+trp = tras 48,50
trc 64,68
rrds 6,8
rrdl 8,10
x4 - x8 rrds tfaw = 48
faw dlr 0
faw slr 0
twtrs 4,6
twtrl 11,14
twr 20,22
trcpage 0
rdrdscl 6,8
wrwrscl 6,8
trfc 514<left this one on auto always
trfcns 350,455<left this one on auto always
tcwl cas or cas-1 = 16,15
trtp 12,14
trdwr 7,8
twrrd 7,8
twrwrsc 1
twrwrsd 7,8
twrwrdd 7,8
twrdrdsc 1
twrdrdsd 5,8
twrdrddd 5,8
tcke 8

These are timings taken from my 2933mhz 600% hci run with the c14d kit. I have never passed another run again. I came here because I saw @catsay help someone who seemed to be in the same boat as me.

What’s the motherboard? Asrock boards have always been picky when it comes to ram compatibility, so there can be that…

Oh… Sorry… I missed that. Somehow…

Since it’s in there, I see no reason a working ram kit shouldn’t be fine. So my guess is either the ram kits are bad, or there are motherboard issues.
On top of that 2133 should work regardless of the brand and model. So my guess is bad motherboard… Can you try and RMA the thing?

Set all clocks / voltages to stock.

Try run RAM at 2133 (that’s stock speed IIRC with DDR4?).

Doesn’t work? RMA RAM or the motherboard. Given you have 2 kits that don’t work, i’d say the chance it is the RAM is low (one bad kit would be unlucky, 2 bad kits at this low speed = colour me sceptical) and it may be the board, as per above (or maybe even the CPU itself?).

If you can somehow test the RAM in a different system and it works, I’d go through the motherboard RMA process.

1 Like

You could be unlucky but more than likely … you have not set up a good configuration for the ram.

Unlike some peoples opinion … Asrock mbs are decently forgiving.

Setting correct voltages and ram timings are important. Mostly it is a piece of cake in this day and age.

1 Like

So early morning here.
You say 2133MHz doesn’t work?

This is rather worrying, I can understand if 2933 doesn’t work but not 2133. Because if Jedec speed isn’t working, how are you getting into the UEFI to set ram timings at all?


DDR4-2133 is “standard” speed for DDR4 i thought.

You shouldn’t need to go tweaking to have 2133 working… it should work out of the box?

i.e., it’s not an asrock thing, it’s not a tuning thing - it’s a broken hardware thing. only question is which bit is broken.

Catsay could line things out in greater detail but you should not have the issue you have at that level…I would lean toward mb at this level of non infomation. It could also be your ram. It has been awhile since I have seen ram that booted but failed in use of something. Normal stock stuff. It either boots or it don’t without overclocking becoming a factor.

Bios sometimes freezes. It’ll post the 3200c14d kit at 3200mhz with the c14d timings at 1.35v and 1.1v soc. Honestly all the testing I’ve done it doesn’t seem to really change anything. If it’s a bad setting it’ll instantly crash. If it’s a good setting it’ll die at about 50%-100%. I can’t figure out how it could pass 600% hci to never do it again. It’s like all logic has left this now. I have screenshots of everything when it passed to keep my sanity coming from the c16d kit which won’t post at 3200mhz. Even single sticks fail with each kit. Is it possible the soc is bad? Idk my brain is done and nothing makes sense. Only thing I haven’t tried now is slacking the trfc if that is even a thing but why am I having to do that to run 2133mhz anyways? Just hoping a auto setting is off but I’ve turned every dial both ways. Was hoping maybe someone could give me some timings that if they fail guarantees its defective hardware and not a bad auto value or something. Also kmode blue screens mean the cpu core voltage was low but its stock and over volted so Idk what’s going on. I know that at least used to be true.

If even the UEFI(BIOS) interface freezes you have serious hardware problems.

Consider reseating your CPU or just taking everything out of the case and try running it with a single ram module with everything on the cardboard main board box.

Also post your CPU UA number. Should be PGT or PGS 17XX something.

If you get the same behaviour still its best to consider RMA’ing your main board or processor. Which exactly depends on further information.

1 Like

I will get the cpu ua number and reseat the cpu after I get some sleep, is there a recommended way to remove the cooler without ripping out the cpu?

Turn it or slide it off sideways rather than lifting straight up.

1 Like

Check the RAM reviews again. If they shipped a bad batch, the recent reviews will probably be flooded with 1-star reviews by now, which would explain your troubles. Else, the probability of getting 2 dead kits by chance are slim (especially if neither stick works on its own, meaning that every single stick is borked). Money on defective mobo.

1 Like

Best case is to run a stress test a bit beforehand to warm up the compound. If you can’t do that, do what catsay said

Hello everyone, some new updates, turned out to be a borked windows install of all things. I have the kit running at 3200mhz 1T gear down mode disabled auto timings(passed hci memtest 500%) however the xmp timings wont stick and after fixing trfc to actually apply what the bios shows it’s still not working after a bit of testing. I just want to make sure the timings are valid before I go dumping volts into the dimms.
Memory kit is f43200c14 32gvk - https://www.pic-upload.de/view-33001479/F4-3200C14D-32GVK-2.png.html
Timings in RTC are
14 tCL
14 trcdwr
14 trcdrd
14 trp
34 tras
48 trc
6 trrds
8 ttrdl
39 tfaw
0 tfawdlr
0 tfawslr
4 twtrs
12 twtrl
20 twr
0 trcpage
6 trdrdscl
6 twrwrscl
312 trfc
195,000 trfc ns
14 tcwl
12 trtp
7 trdwr
3 twrrd
1 twrwrsc
7 twrwrsd
7 twrwrdd
1 trdrdsc
5 trdrdsd
5 trdrddd
8 tcke

You can kinda bypass everything by setting hertz and all of that to maximum, then you slowly key them down one by one
Which also works best for being unsure of that mess, just set the suspected thing to worst setting

Also, one way to do that is to set everything to their maximums and just and only focus to “twr”, there are just couple settings which seem to affect each other

Bonus note:
You end up noticing that you should have trusted earlier setting, and its just that for example tdrdscl whats so damn eccentric that it needs 10 instead of 6 :man_shrugging:t2:

I want to actually use my PC sometimes note:
Write down stable settings and just key them on top of XMP, maybe it crashes less frequently :man_shrugging:t2::man_shrugging:t2:

If I set trdrdscl or twrwrscl higher to like 10 I think it was I can get the timings to work but I don’t think that’s achieving anything cause it’s overall slower. Also haven’t seen anyone running higher than 6. I do understand where your coming from though. I just think it’s a mess of timings and so far haven’t found secondary timings for a dual rank kit anywhere and the auto values the board sets are wonky at best I just found out today it wasn’t setting trfc right after reading someone talking about it on reddit, went and checked, sure enough, 312trfc in bios, 560 in RTC after I manually set the trfc it changed in RTC but didn’t help stability.

Those are dual rank 16GB sticks. Asus QVL only lists single rank 8GB sticks.
For good reason, it seems like.

Pictorial super guide :sparkler:



I understand the methodology. =P

Is it just me or does trfc, trfc2, and trfc4 not get calculated correctly because auto values are 312 192 132 but 312 / 1.34 is 232.8 and 312 / 1.625 is 192 but 192 /1.34 is 143.2 and 192 / 1.625 is 118 so where are these values coming from?(I know it’s trfc / 1.34 = trfc2 / 1.625 = trfc4) It’s closer to 312 / 1.625 = 192 / 1.45 = 132 or its 1.46 and rounded up.