144/60hz monitors w/kde

I just bought a shiny new 144hz Monitor but i cant get a dual display setup working with both my [email protected] and [email protected] running at their respective frame rates

Currently running KDE 5.59.0
Nvidia 430.40
Fedora 30

Examples :
If both monitors are plugged in
https://www.testufo.com/ Will only read a max of 60fps
glxgears Maxed to 60
Hollow Knight will recognize I have a 144hz monitor but with vsync on will out output 60
CS:GO with vsync on with only output 60

If i unplug my second monitor all the examples will jump to 144 without reboot, re-log or relaunch of the application the only thing that seems to work if the second monitor is plugged in my mouse is noticeably refreshing much faster then everything else

Things I have Tried
Setting custom window rules for CS:GO and Hollow knight to Force Block compositing
image

Editing ~/.config/kwinrc to include
[Compositing]
MaxFPS=144
OpenGLIsUnsafe=false
RefreshRate=144

Force Full/Normal Composition Pipeline on and off

To be clear my monitor is set to 144hz it just doesn’t seem to do anything

Please determine if you are running X or wayland.
X does not support mixed Refreshrates. I’m in the same situation with one 144Hz Monitor and two 60Hz ones. X sees all Monitors as a single screen. So your refreshrate is limited to what ever the lowest is a connected monitor has (60Hz in your case).

This doesn’t affect applications in exclusive Fullscreen though (Games for me run fine at 144FPS).

Also, make sure in the nvidia-settings, to enable “Force Full Composite Pipeline” after showing advanced options. This should help a bit. But it doesn’t change the inherent situation with X. (Edit: just read that you did that allready. nvm.)

With wayland it’s a bit different. But we can look into that once we determine you are actually running wayland (which i doubt).

I’m Currently Running x11
Edit: I did try Setting application to full screen using kwin key-binds


And the Custom window setting but nither worked

Your monitor is working properly.
KDE as long as you don’t force vsync in compositor settings should be working at 144hz.

This one depends on browser. Chrome currently I am not aware that supports 144hz on linux.
On firefox you need to enable some options look up “linux firefox 144hz” in a search engine.

this is always running at 60

Vsync for me at least always limits to 60 fps.

Easiest test to make sure you have one of the monitors at a higher refresh rate is to enable some windows effect like “wobbly windows” ( get into it’s settings and increase the effect to the max) and then move it between the two monitors. then you will be able to notice a stuttering kind of effect on the 60hz monitor and smooth animation on the 144hz.

If you have more questions feel free to ask me.

This is not the same as “Exclusive Fullscreen” for an application. In Exclusive mode, KDE, your compositor and such have no say in what the application does anymore, more or less. That’s why the 60Hz limitation doesn’t apply there.

So you say that X11 is supporting mixed refreshrate, running one screen at 60 Hz and one at144? The only way i ever got that to work was by running two seperate X Server Instances. Anything else, the DE or Settings or Nvidia report 144Hz, but other than Fullscreen games i was always limited to 60Hz. The difference is quite noticeable when i disconnect my other Monitors.

Yes and no. Thinking about it I haven’t tested nvidia GPU as I don’t own one at the moment. But I know of a different user that has 2 monitors with different refresh rates and nvidia GPU without problems on kde.
@SesameStreetThug feel free to correct me if I am wrong about your current status.

I have 2 [email protected] and a [email protected] and ufotest behaves as you expect, 60fps on the side monitors and 75fps on the middle. it is worth noting however that my difference in refreshrate is small, and I do not use vsync

As far as I can tell X does support mixed refresh rates, I have 4 monitors and 3 of them are set to 75 Hz and one is set to 100 Hz. If I run glxgears it reports 100 FPS when on the 100 Hz monitor and 75 on the rest. The difference between 60 or 75 and 100 Hz is noticeable. I don’t have any 144 Hz panels to know if it works properly that high but seems like it should. Otherwise yes Chrome only supports 60 FPS on Linux and hardware acceleration is still kind of a mixed bag.

So I changed my second monitor out for a 30hz one a vsync was caped at 30 to is not picking 60hz but the lowest hz monitor


According to @lessaj and @SesameStreetThugIT works just as you would expect it to so i got to be do something wrong

So I have to ask what settings did you apply here -

Didn’t touch my settings was default Opengl 2.0

But i figured it out!


Added __GL_SYNC_DISPLAY_DEVICE=DP-4 to my /etc/environment
Corsponding to my 144hz monitor on xrandr -q and Ufo Busters glxgears Hollow knight and csgo all run at 144hz

1 Like

Mh that’s funny you had to add that…

Might be something in the distribution, but I just plugged in my 144Hz Monitor (second monitor is HDMI -> VGA at 60 Hz), set it in the KDE Display settings and this happens:

[[email protected] ~]$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
721 frames in 5.0 seconds = 144.195 FPS
720 frames in 5.0 seconds = 143.973 FPS
720 frames in 5.0 seconds = 143.970 FPS

Sooo, not sure why you needed that? Maybe this is set by default on Fedora…

/edit
Actually, just realised you were on nvidia. Might be something to do with that, since that’s what they mention in the GitLab issue as well. AMD here so… maybe driver implementation.